What’s Vulnerable › Vulnerabilities
CVE-2022-0345: Better Notifications for WP < 1.8.7 - Email Address Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-352
Description
The Customize WordPress Emails and Alerts WordPress plugin before 1.8.7 does not have authorisation and CSRF check in its bnfw_search_users AJAX action, allowing any authenticated users to call it and query for user e-mail prefixes (finding the first letter, then the second one, then the third one etc.).
Affected products
- Customize WordPress Emails and Alerts: before 1.8.7 — fixed in 1.8.7
How to fix
Upgrade to a fixed version: Customize WordPress Emails and Alerts 1.8.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b3b523b9-6c92-4091-837a-d34e3174eb19
- https://wpscan.com/vulnerability/b3b523b9-6c92-4091-837a-d34e3174eb19
Get alerted when CVE-2022-0345 or the next vulnerability affects your stack