What’s Vulnerable › Vulnerabilities
CVE-2022-0350: Cross-site Scripting (XSS) - Stored in vanessa219/vditor
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository vanessa219/vditor prior to 3.8.13.
Affected products
- vanessa219/vditor: before 3.8.13 — fixed in 3.8.13
How to fix
Upgrade to a fixed version: vanessa219/vditor 3.8.13. Check the vendor advisory for mitigations.
References
- https://github.com/vanessa219/vditor/commit/e912e36ea98251d700499b1ac7702708d3398476
- https://huntr.dev/bounties/8202aa06-4b49-45ff-aa0f-00982f62005c
- https://github.com/vanessa219/vditor/commit/e912e36ea98251d700499b1ac7702708d3398476
- https://huntr.dev/bounties/8202aa06-4b49-45ff-aa0f-00982f62005c
Get alerted when CVE-2022-0350 or the next vulnerability affects your stack