What’s Vulnerable › Vulnerabilities
CVE-2022-0352: Cross-site Scripting (XSS) - Reflected in janeczku/calibre-web
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.
Affected products
- janeczku/calibre-web: before 0.6.16 — fixed in 0.6.16
How to fix
Upgrade to a fixed version: janeczku/calibre-web 0.6.16. Check the vendor advisory for mitigations.
References
- https://github.com/janeczku/calibre-web/commit/6bf07539788004513c3692c074ebc7ba4ce005e1
- https://huntr.dev/bounties/a577ff17-2ded-4c41-84ae-6ac02440f717
- https://github.com/janeczku/calibre-web/commit/6bf07539788004513c3692c074ebc7ba4ce005e1
- https://huntr.dev/bounties/a577ff17-2ded-4c41-84ae-6ac02440f717
Get alerted when CVE-2022-0352 or the next vulnerability affects your stack