What’s Vulnerable › Vulnerabilities
CVE-2022-0355: Improper Removal of Sensitive Information Before Storage or Transfer in feross/simple-get
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-26 · updated 2026-06-17
- Weakness: CWE-212
Description
Improper Removal of Sensitive Information Before Storage or Transfer in NPM simple-get prior to 4.0.1.
Affected products
- feross/simple-get: before 2.8.2; from 3.0.0 before 3.1.1; 4.0.0 — fixed in 2.8.2, 3.1.1
How to fix
Upgrade to a fixed version: feross/simple-get 2.8.2, 3.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-wpg7-2c88-r8xv
- https://github.com/feross/simple-get/commit/e4af095e06cd69a9235013e8507e220a79b9684f
- https://huntr.dev/bounties/42c79c23-6646-46c4-871d-219c0d4b4e31
- https://github.com/advisories/GHSA-wpg7-2c88-r8xv
- https://github.com/feross/simple-get/commit/e4af095e06cd69a9235013e8507e220a79b9684f
- https://huntr.dev/bounties/42c79c23-6646-46c4-871d-219c0d4b4e31
Get alerted when CVE-2022-0355 or the next vulnerability affects your stack