What’s Vulnerable › Vulnerabilities
CVE-2022-0359: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-26 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: from 12.0 before 12.6 — fixed in 12.6
- Debian Linux: 9.0, 10.0
- vim/vim: before 8.2.4214 — fixed in 8.2.4214
How to fix
Upgrade to a fixed version: Apple macOS 12.6; vim/vim 8.2.4214. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
- https://github.com/vim/vim/commit/85b6747abc15a7a81086db31289cf1b8b17e6cb1
- https://huntr.dev/bounties/a3192d90-4f82-4a67-b7a6-37046cc88def
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213444
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
Get alerted when CVE-2022-0359 or the next vulnerability affects your stack