What’s Vulnerable › Vulnerabilities
CVE-2022-0363: myCred < 2.4.4 - Subscriber+ Arbitrary Post Creation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-25 · updated 2026-06-17
- Weakness: CWE-352
Description
The myCred WordPress plugin before 2.4.3.1 does not have any authorisation and CSRF checks in the mycred-tools-import-export AJAX action, allowing any authenticated users, such as subscribers, to call it and import mycred setup, thus creating badges, managing points or creating arbitrary posts.
Affected products
- Saad Iqbal myCred: before 2.4.3.1 — fixed in 2.4.3.1
How to fix
Upgrade to a fixed version: Saad Iqbal myCred 2.4.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a438a951-497c-43cd-822f-1a48d4315191
- https://wpscan.com/vulnerability/a438a951-497c-43cd-822f-1a48d4315191
Get alerted when CVE-2022-0363 or the next vulnerability affects your stack