What’s Vulnerable › Vulnerabilities
CVE-2022-0367
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-119
Description
A heap-based buffer overflow flaw was found in libmodbus in function modbus_reply() in src/modbus.c.
Affected products
- Debian Linux: 10.0
- Fedoraproject Extra Packages For Enterprise Linux: 7.0
- Fedoraproject Fedora: 35
- libmodbus: before 3.1.7 — fixed in 3.1.7
How to fix
Upgrade to a fixed version: libmodbus 3.1.7. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2045571
- https://github.com/stephane/libmodbus/commit/b4ef4c17d618eba0adccc4c7d9e9a1ef809fc9b6
- https://github.com/stephane/libmodbus/issues/614
- https://lists.debian.org/debian-lts-announce/2022/09/msg00007.html
- https://bugzilla.redhat.com/show_bug.cgi?id=2045571
- https://github.com/stephane/libmodbus/commit/b4ef4c17d618eba0adccc4c7d9e9a1ef809fc9b6
- https://github.com/stephane/libmodbus/issues/614
- https://lists.debian.org/debian-lts-announce/2022/09/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00010.html
Get alerted when CVE-2022-0367 or the next vulnerability affects your stack