What’s Vulnerable › Vulnerabilities
CVE-2022-0368: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-26 · updated 2026-06-17
- Weakness: CWE-125
Description
Out-of-bounds Read in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: from 12.0 before 12.6 — fixed in 12.6
- Debian Linux: 9.0, 10.0
- vim/vim: before 8.2.4217 — fixed in 8.2.4217
How to fix
Upgrade to a fixed version: Apple macOS 12.6; vim/vim 8.2.4217. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
- https://github.com/vim/vim/commit/8d02ce1ed75d008c34a5c9aaa51b67cbb9d33baa
- https://huntr.dev/bounties/bca9ce1f-400a-4bf9-9207-3f3187cb3fa9
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213444
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
Get alerted when CVE-2022-0368 or the next vulnerability affects your stack