What’s Vulnerable › Vulnerabilities
CVE-2022-0392: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-28 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim prior to 8.2.
Affected products
- Apple macOS: from 12.0 before 12.6 — fixed in 12.6
- Debian Linux: 10.0
- vim/vim: before 8.2.4218 — fixed in 8.2.4218
How to fix
Upgrade to a fixed version: Apple macOS 12.6; vim/vim 8.2.4218. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
- https://github.com/vim/vim/commit/806d037671e133bd28a7864248763f643967973a
- https://huntr.dev/bounties/d00a2acd-1935-4195-9d5b-4115ef6b3126
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213444
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
Get alerted when CVE-2022-0392 or the next vulnerability affects your stack