What’s Vulnerable › Vulnerabilities
CVE-2022-0393: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-28 · updated 2026-06-17
- Weakness: CWE-125
Description
Out-of-bounds Read in GitHub repository vim/vim prior to 8.2.
Affected products
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.4233 — fixed in 8.2.4233
How to fix
Upgrade to a fixed version: vim/vim 8.2.4233. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/a4bc2dd7cccf5a4a9f78b58b6f35a45d17164323
- https://huntr.dev/bounties/ecc8f488-01a0-477f-848f-e30b8e524bba
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UFXFAILMLUIK4MBUEZO4HNBNKYZRJ5AP/
- https://security.gentoo.org/glsa/202208-32
- https://github.com/vim/vim/commit/a4bc2dd7cccf5a4a9f78b58b6f35a45d17164323
- https://huntr.dev/bounties/ecc8f488-01a0-477f-848f-e30b8e524bba
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UFXFAILMLUIK4MBUEZO4HNBNKYZRJ5AP/
- https://security.gentoo.org/glsa/202208-32
Get alerted when CVE-2022-0393 or the next vulnerability affects your stack