What’s Vulnerable › Vulnerabilities
CVE-2022-0397: WPC Smart Wishlist for WooCommerce < 2.9.4 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPC Smart Wishlist for WooCommerce WordPress plugin before 2.9.4 does not sanitise and escape the key parameter before outputting it back in the wishlist_quickview AJAX action's response (available to any authenticated user), leading to a Reflected Cross-Site Scripting
Affected products
- WPC Smart Wishlist for WooCommerce: before 2.9.4 — fixed in 2.9.4
How to fix
Upgrade to a fixed version: WPC Smart Wishlist for WooCommerce 2.9.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c8091254-1ced-4363-ab7f-5b880447713d
- https://wpscan.com/vulnerability/c8091254-1ced-4363-ab7f-5b880447713d
Get alerted when CVE-2022-0397 or the next vulnerability affects your stack