What’s Vulnerable › Vulnerabilities
CVE-2022-0399: Advanced Product Labels for WooCommerce < 1.2.3.7 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced Product Labels for WooCommerce WordPress plugin before 1.2.3.7 does not sanitise and escape the tax_color_set_type parameter before outputting it back in the berocket_apl_color_listener AJAX action's response, leading to a Reflected Cross-Site Scripting
Affected products
- Advanced Product Labels for WooCommerce: before 1.2.3.7 — fixed in 1.2.3.7
How to fix
Upgrade to a fixed version: Advanced Product Labels for WooCommerce 1.2.3.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2678919
- https://wpscan.com/vulnerability/5e5fdcf4-ec2b-4e73-8009-05606b2d5164
- https://plugins.trac.wordpress.org/changeset/2678919
- https://wpscan.com/vulnerability/5e5fdcf4-ec2b-4e73-8009-05606b2d5164
Get alerted when CVE-2022-0399 or the next vulnerability affects your stack