What’s Vulnerable › Vulnerabilities
CVE-2022-0401: Path Traversal in yuda-lyu/w-zip
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-22
Description
Path Traversal in NPM w-zip prior to 1.0.12.
Affected products
- yuda-lyu/w-zip: before 1.0.12 — fixed in 1.0.12
How to fix
Upgrade to a fixed version: yuda-lyu/w-zip 1.0.12. Check the vendor advisory for mitigations.
References
- https://github.com/yuda-lyu/w-zip/commit/d7039d034e02fa358e6656565157cedf5fa83288
- https://huntr.dev/bounties/d93259aa-ad03-43d6-8846-a00b9f58876d
- https://github.com/yuda-lyu/w-zip/commit/d7039d034e02fa358e6656565157cedf5fa83288
- https://huntr.dev/bounties/d93259aa-ad03-43d6-8846-a00b9f58876d
Get alerted when CVE-2022-0401 or the next vulnerability affects your stack