What’s Vulnerable › Vulnerabilities
CVE-2022-0402: Superforms < 6.0.4 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Super Forms - Drag & Drop Form Builder WordPress plugin before 6.0.4 does not escape the bob_czy_panstwa_sprawa_zostala_rozwiazana parameter before outputting it back in an attribute via the super_language_switcher AJAX action, leading to a Reflected Cross-Site Scripting. The action is also lacking CSRF, making the attack easier to perform against any user.
Affected products
- Super Forms - Drag & Drop Form Builder: before 6.0.4 — fixed in 6.0.4
How to fix
Upgrade to a fixed version: Super Forms - Drag & Drop Form Builder 6.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/RensTillmann/super-forms/commit/c19d65abbe43d9b6359c1bf3498dc697d0c19d02
- https://wpscan.com/vulnerability/2e2e2478-2488-4c91-8af8-69b07783854f/
- https://github.com/RensTillmann/super-forms/commit/c19d65abbe43d9b6359c1bf3498dc697d0c19d02
- https://wpscan.com/vulnerability/2e2e2478-2488-4c91-8af8-69b07783854f/
Get alerted when CVE-2022-0402 or the next vulnerability affects your stack