What’s Vulnerable › Vulnerabilities
CVE-2022-0403: Library File Manager < 5.2.3 - Subscriber+ Arbitrary File Creation/Upload/Deletion
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-434
Description
The Library File Manager WordPress plugin before 5.2.3 is using an outdated version of the elFinder library, which is know to be affected by security issues (CVE-2021-32682), and does not have any authorisation as well as CSRF checks in its connector AJAX action, allowing any authenticated users, such as subscriber to call it. Furthermore, as the options passed to the elFinder library does not restrict any file type, users with a role as low as subscriber can Create/Upload/Delete Arbitrary files and folders.
Affected products
- Library File Manager: before 5.2.3 — fixed in 5.2.3
How to fix
Upgrade to a fixed version: Library File Manager 5.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/997a7fbf-98c6-453e-ad84-75c1e91d5a1e
- https://wpscan.com/vulnerability/997a7fbf-98c6-453e-ad84-75c1e91d5a1e
Get alerted when CVE-2022-0403 or the next vulnerability affects your stack