What’s Vulnerable › Vulnerabilities
CVE-2022-0407: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-30 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.
Affected products
- vim/vim: before 8.2.4219 — fixed in 8.2.4219
How to fix
Upgrade to a fixed version: vim/vim 8.2.4219. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/44db8213d38c39877d2148eff6a72f4beccfb94e
- https://huntr.dev/bounties/81822bf7-aafe-4d37-b836-1255d46e572c
- https://security.gentoo.org/glsa/202208-32
- https://github.com/vim/vim/commit/44db8213d38c39877d2148eff6a72f4beccfb94e
- https://huntr.dev/bounties/81822bf7-aafe-4d37-b836-1255d46e572c
- https://security.gentoo.org/glsa/202208-32
Get alerted when CVE-2022-0407 or the next vulnerability affects your stack