What’s Vulnerable › Vulnerabilities
CVE-2022-0412: TI WooCommerce Wishlist < 1.40.1 - Unauthenticated Blind SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 74.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-89
Description
The TI WooCommerce Wishlist WordPress plugin before 1.40.1, TI WooCommerce Wishlist Pro WordPress plugin before 1.40.1 do not sanitise and escape the item_id parameter before using it in a SQL statement via the wishlist/remove_product REST endpoint, allowing unauthenticated attackers to perform SQL injection attacks
Affected products
- templateinvaders TI WooCommerce Wishlist: before 1.40.1 — fixed in 1.40.1
How to fix
Upgrade to a fixed version: templateinvaders TI WooCommerce Wishlist 1.40.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2668899
- https://wpscan.com/vulnerability/e984ba11-abeb-4ed4-9dad-0bfd539a9682
- https://plugins.trac.wordpress.org/changeset/2668899
- https://wpscan.com/vulnerability/e984ba11-abeb-4ed4-9dad-0bfd539a9682
Get alerted when CVE-2022-0412 or the next vulnerability affects your stack