What’s Vulnerable › Vulnerabilities
CVE-2022-0413: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-30 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 8.2.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.4253 — fixed in 8.2.4253
How to fix
Upgrade to a fixed version: vim/vim 8.2.4253. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/37f47958b8a2a44abc60614271d9537e7f14e51a
- https://huntr.dev/bounties/563d1e8f-5c3d-4669-941c-3216f4a87c38
- https://lists.debian.org/debian-lts-announce/2022/05/msg00022.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UFXFAILMLUIK4MBUEZO4HNBNKYZRJ5AP/
- https://security.gentoo.org/glsa/202208-32
- https://github.com/vim/vim/commit/37f47958b8a2a44abc60614271d9537e7f14e51a
- https://huntr.dev/bounties/563d1e8f-5c3d-4669-941c-3216f4a87c38
- https://lists.debian.org/debian-lts-announce/2022/05/msg00022.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
Get alerted when CVE-2022-0413 or the next vulnerability affects your stack