What’s Vulnerable › Vulnerabilities
CVE-2022-0417: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow GitHub repository vim/vim prior to 8.2.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.4245 — fixed in 8.2.4245
How to fix
Upgrade to a fixed version: vim/vim 8.2.4245. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/652dee448618589de5528a9e9a36995803f5557a
- https://huntr.dev/bounties/fc86bc8d-c866-4ade-8b7f-e49cec306d1a
- https://lists.debian.org/debian-lts-announce/2022/06/msg00014.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UFXFAILMLUIK4MBUEZO4HNBNKYZRJ5AP/
- https://security.gentoo.org/glsa/202208-32
- https://github.com/vim/vim/commit/652dee448618589de5528a9e9a36995803f5557a
- https://huntr.dev/bounties/fc86bc8d-c866-4ade-8b7f-e49cec306d1a
- https://lists.debian.org/debian-lts-announce/2022/06/msg00014.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
Get alerted when CVE-2022-0417 or the next vulnerability affects your stack