What’s Vulnerable › Vulnerabilities
CVE-2022-0420: RegistrationMagic < 5.0.2.2 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-89
Description
The RegistrationMagic WordPress plugin before 5.0.2.2 does not sanitise and escape the rm_form_id parameter before using it in a SQL statement in the Automation admin dashboard, allowing high privilege users to perform SQL injection attacks
Affected products
- Metagauss RegistrationMagic: before 5.0.2.2 — fixed in 5.0.2.2
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 5.0.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2672042
- https://wpscan.com/vulnerability/056b5167-3cbc-47d1-9917-52a434796151
- https://plugins.trac.wordpress.org/changeset/2672042
- https://wpscan.com/vulnerability/056b5167-3cbc-47d1-9917-52a434796151
Get alerted when CVE-2022-0420 or the next vulnerability affects your stack