What’s Vulnerable › Vulnerabilities
CVE-2022-0421: Five Star Restaurant Reservations < 2.4.12 - Unauthenticated Arbitrary Payment Status Update to Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-21 · updated 2026-06-17
- Weakness: CWE-116
Description
The Five Star Restaurant Reservations WordPress plugin before 2.4.12 does not have authorisation when changing whether a payment was successful or failed, allowing unauthenticated users to change the payment status of arbitrary bookings. Furthermore, due to the lack of sanitisation and escaping, attackers could perform Cross-Site Scripting attacks against a logged in admin viewing the failed payments
Affected products
- Five Star Restaurant Reservations: before 2.4.12 — fixed in 2.4.12
How to fix
Upgrade to a fixed version: Five Star Restaurant Reservations 2.4.12. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/145e8d3c-cd6f-4827-86e5-ea2d395a80b9
- https://wpscan.com/vulnerability/145e8d3c-cd6f-4827-86e5-ea2d395a80b9
Get alerted when CVE-2022-0421 or the next vulnerability affects your stack