What’s Vulnerable › Vulnerabilities
CVE-2022-0422: White Label MS < 2.2.9 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The White Label CMS WordPress plugin before 2.2.9 does not sanitise and validate the wlcms[_login_custom_js] parameter before outputting it back in the response while previewing, leading to a Reflected Cross-Site Scripting issue
Affected products
- White Label CMS: before 2.2.9 — fixed in 2.2.9
How to fix
Upgrade to a fixed version: White Label CMS 2.2.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2672615
- https://wpscan.com/vulnerability/429be4eb-8a6b-4531-9465-9ef0d35c12cc
- https://plugins.trac.wordpress.org/changeset/2672615
- https://wpscan.com/vulnerability/429be4eb-8a6b-4531-9465-9ef0d35c12cc
Get alerted when CVE-2022-0422 or the next vulnerability affects your stack