What’s Vulnerable › Vulnerabilities
CVE-2022-0428: Content Egg < 5.3.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Content Egg WordPress plugin before 5.3.0 does not sanitise and escape the page parameter before outputting back in an attribute in the Autoblogging admin dashboard, leading to a Reflected Cross-Site Scripting
Affected products
- Content Egg: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: Content Egg 5.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/071a2f69-9cd6-42a8-a56c-264a589784ab
- https://wpscan.com/vulnerability/071a2f69-9cd6-42a8-a56c-264a589784ab
Get alerted when CVE-2022-0428 or the next vulnerability affects your stack