What’s Vulnerable › Vulnerabilities
CVE-2022-0430: Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-15 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.
Affected products
- httpie: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: httpie 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/httpie/httpie/commit/65ab7d5caaaf2f95e61f9dd65441801c2ddee38b
- https://huntr.dev/bounties/dafb2e4f-c6b6-4768-8ef5-b396cd6a801f
- https://github.com/httpie/httpie/commit/65ab7d5caaaf2f95e61f9dd65441801c2ddee38b
- https://huntr.dev/bounties/dafb2e4f-c6b6-4768-8ef5-b396cd6a801f
Get alerted when CVE-2022-0430 or the next vulnerability affects your stack