What’s Vulnerable › Vulnerabilities
CVE-2022-0436: Path Traversal in gruntjs/grunt
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-12 · updated 2026-06-17
- Weakness: CWE-22
Description
Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.
Affected products
- gruntjs/grunt: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: gruntjs/grunt 1.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/gruntjs/grunt/commit/aad3d4521c3098fb255fb2db8f2e1d691a033665
- https://huntr.dev/bounties/f55315e9-9f6d-4dbb-8c40-bae50c1ae92b
- https://lists.debian.org/debian-lts-announce/2023/04/msg00008.html
- https://github.com/gruntjs/grunt/commit/aad3d4521c3098fb255fb2db8f2e1d691a033665
- https://huntr.dev/bounties/f55315e9-9f6d-4dbb-8c40-bae50c1ae92b
- https://lists.debian.org/debian-lts-announce/2023/04/msg00008.html
Get alerted when CVE-2022-0436 or the next vulnerability affects your stack