What’s Vulnerable › Vulnerabilities
CVE-2022-0439: Email Subscribers & Newsletters < 5.3.2 - Subscriber+ Blind SQL injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-89
Description
The Email Subscribers & Newsletters WordPress plugin before 5.3.2 does not correctly escape the `order` and `orderby` parameters to the `ajax_fetch_report_list` action, making it vulnerable to blind SQL injection attacks by users with roles as low as Subscriber. Further, it does not have any CSRF protection in place for the action, allowing an attacker to trick any logged in user to perform the action by clicking a link.
Affected products
- icegram Email Subscribers & Newsletters – Email Marketing, Post Notifications & Newsletter Plugin for WordPress: before 5.3.2 — fixed in 5.3.2
How to fix
Upgrade to a fixed version: icegram Email Subscribers & Newsletters – Email Marketing, Post Notifications & Newsletter Plugin for WordPress 5.3.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/729d3e67-d081-4a4e-ac1e-f6b0a184f095
- https://wpscan.com/vulnerability/729d3e67-d081-4a4e-ac1e-f6b0a184f095
Get alerted when CVE-2022-0439 or the next vulnerability affects your stack