What’s Vulnerable › Vulnerabilities
CVE-2022-0443: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-02 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 8.2.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.4281 — fixed in 8.2.4281
How to fix
Upgrade to a fixed version: vim/vim 8.2.4281. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/9b4a80a66544f2782040b641498754bcb5b8d461
- https://huntr.dev/bounties/b987c8cb-bbbe-4601-8a6c-54ff907c6b51
- https://lists.debian.org/debian-lts-announce/2022/05/msg00022.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UFXFAILMLUIK4MBUEZO4HNBNKYZRJ5AP/
- https://security.gentoo.org/glsa/202208-32
- https://github.com/vim/vim/commit/9b4a80a66544f2782040b641498754bcb5b8d461
- https://huntr.dev/bounties/b987c8cb-bbbe-4601-8a6c-54ff907c6b51
- https://lists.debian.org/debian-lts-announce/2022/05/msg00022.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
Get alerted when CVE-2022-0443 or the next vulnerability affects your stack