What’s Vulnerable › Vulnerabilities
CVE-2022-0448: CP Blocks < 1.0.15 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The CP Blocks WordPress plugin before 1.0.15 does not sanitise and escape its "License ID" settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed.
Affected products
- CP Blocks: before 1.0.15 — fixed in 1.0.15
How to fix
Upgrade to a fixed version: CP Blocks 1.0.15. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d4ff63ee-28e6-486e-9aa7-c878b97f707c
- https://wpscan.com/vulnerability/d4ff63ee-28e6-486e-9aa7-c878b97f707c
Get alerted when CVE-2022-0448 or the next vulnerability affects your stack