What’s Vulnerable › Vulnerabilities
CVE-2022-0449: Flexi - Guest Submit < 4.20 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Flexi WordPress plugin before 4.20 does not sanitise and escape various parameters before outputting them back in some pages such as the user dashboard, leading to a Reflected Cross-Site Scripting
Affected products
- Flexi – Guest Submit: before 4.20 — fixed in 4.20
How to fix
Upgrade to a fixed version: Flexi – Guest Submit 4.20. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3cc1bb3c-e124-43d3-bc84-a493561a1387
- https://wpscan.com/vulnerability/3cc1bb3c-e124-43d3-bc84-a493561a1387
Get alerted when CVE-2022-0449 or the next vulnerability affects your stack