What’s Vulnerable › Vulnerabilities
CVE-2022-0450: Menu Image, Icons made easy < 3.0.8 - Subscriber+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-28 · updated 2026-06-17
- Weakness: CWE-116
Description
The Menu Image, Icons made easy WordPress plugin before 3.0.6 does not have authorisation and CSRF checks when saving menu settings, and does not validate, sanitise and escape them. As a result, any authenticate users, such as subscriber can update the settings or arbitrary menu and put Cross-Site Scripting payloads in them which will be triggered in the related menu in the frontend
Affected products
- Menu Image, Icons made easy: before 3.0.8 — fixed in 3.0.8
How to fix
Upgrade to a fixed version: Menu Image, Icons made easy 3.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/612f9273-acc8-4be6-b372-33f1e687f54a
- https://wpscan.com/vulnerability/612f9273-acc8-4be6-b372-33f1e687f54a
Get alerted when CVE-2022-0450 or the next vulnerability affects your stack