What’s Vulnerable › Vulnerabilities

CVE-2022-0477

Description

An issue has been discovered in GitLab affecting all versions starting from 11.9 before 14.5.4, all versions starting from 14.6.0 before 14.6.4, all versions starting from 14.7.0 before 14.7.1. GitLab was not correctly handling bulk requests to delete existing packages from the package registries which could result in a Denial of Service under specific conditions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.5.4, 14.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-0477 or the next vulnerability affects your stack