What’s Vulnerable › Vulnerabilities
CVE-2022-0478: Event Manager for WooCommerce < 3.5.8 - Contributor+ SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-89
Description
The Event Manager and Tickets Selling for WooCommerce WordPress plugin before 3.5.8 does not validate and escape the post_author_gutenberg parameter before using it in a SQL statement when creating/editing events, which could allow users with a role as low as contributor to perform SQL Injection attacks
Affected products
- MagePeople Team Event Manager and Tickets Selling Plugin for WooCommerce: before 3.5.8 — fixed in 3.5.8
How to fix
Upgrade to a fixed version: MagePeople Team Event Manager and Tickets Selling Plugin for WooCommerce 3.5.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2671860
- https://wpscan.com/vulnerability/d881d725-d06b-464f-a25e-88f41b1f431f
- https://plugins.trac.wordpress.org/changeset/2671860
- https://wpscan.com/vulnerability/d881d725-d06b-464f-a25e-88f41b1f431f
Get alerted when CVE-2022-0478 or the next vulnerability affects your stack