What’s Vulnerable › Vulnerabilities
CVE-2022-0479: Popup Builder < 4.1.1 - SQL Injection to Reflected Cross-Site Scripting
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 43.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-28 · updated 2026-06-17
- Weakness: CWE-89
Description
The Popup Builder WordPress plugin before 4.1.1 does not sanitise and escape the sgpb-subscription-popup-id parameter before using it in a SQL statement in the All Subscribers admin dashboard, leading to a SQL injection, which could also be used to perform Reflected Cross-Site Scripting attack against a logged in admin opening a malicious link
Affected products
- Popup Builder: before 4.1.1 — fixed in 4.1.1
How to fix
Upgrade to a fixed version: Popup Builder 4.1.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2686454
- https://wpscan.com/vulnerability/0d2bbbaf-fbfd-4921-ba4e-684e2e77e816
- https://plugins.trac.wordpress.org/changeset/2686454
- https://wpscan.com/vulnerability/0d2bbbaf-fbfd-4921-ba4e-684e2e77e816
Get alerted when CVE-2022-0479 or the next vulnerability affects your stack