What’s Vulnerable › Vulnerabilities
CVE-2022-0489
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting with 8.15 . It was possible to trigger a DOS by using the math feature with a specific formula in issue comments.
Affected products
- GitLab: from 8.15.0 before 14.6.5; from 14.7.0 through 14.7.4; from 14.8.0 before 14.8.2 — fixed in 14.6.5, 14.8.2
How to fix
Upgrade to a fixed version: GitLab 14.6.5, 14.8.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-0489.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/341832
- https://hackerone.com/reports/1350793
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-0489.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/341832
- https://hackerone.com/reports/1350793
Get alerted when CVE-2022-0489 or the next vulnerability affects your stack