What’s Vulnerable › Vulnerabilities
CVE-2022-0493: String Locator < 2.5.0 - Admin+ Arbitrary File Read
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-28 · updated 2026-06-17
- Weakness: CWE-22
Description
The String locator WordPress plugin before 2.5.0 does not properly validate the path of the files to be searched, allowing high privilege users such as admin to query arbitrary files on the web server via a path traversal vector. Furthermore, due to a flaw in the search, allowing a pattern to be provided, which will be used to output the relevant matches from the matching file, all content of the file can be disclosed.
Affected products
- String locator: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: String locator 2.5.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2685592
- https://wpscan.com/vulnerability/21e2e5fc-03d2-4791-beef-07af6bf985ed
- https://plugins.trac.wordpress.org/changeset/2685592
- https://wpscan.com/vulnerability/21e2e5fc-03d2-4791-beef-07af6bf985ed
Get alerted when CVE-2022-0493 or the next vulnerability affects your stack