What’s Vulnerable › Vulnerabilities
CVE-2022-0494
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-25 · updated 2026-06-17
- Weakness: CWE-200
Description
A kernel information leak flaw was identified in the scsi_ioctl function in drivers/scsi/scsi_ioctl.c in the Linux kernel. This flaw allows a local attacker with a special user privilege (CAP_SYS_ADMIN or CAP_SYS_RAWIO) to create issues with confidentiality.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Linux kernel: before 5.17; 5.17, 5.17-rc1, 5.17-rc2, 5.17-rc3, 5.17-rc4 — fixed in 5.17
How to fix
Upgrade to a fixed version: Linux kernel 5.17. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2039448
- https://lists.debian.org/debian-lts-announce/2022/07/msg00000.html
- https://lore.kernel.org/all/20220216084038.15635-1-tcs.kernel%40gmail.com/
- https://www.debian.org/security/2022/dsa-5161
- https://www.debian.org/security/2022/dsa-5173
- https://bugzilla.redhat.com/show_bug.cgi?id=2039448
- https://lists.debian.org/debian-lts-announce/2022/07/msg00000.html
- https://lore.kernel.org/all/20220216084038.15635-1-tcs.kernel%40gmail.com/
- https://www.debian.org/security/2022/dsa-5161
- https://www.debian.org/security/2022/dsa-5173
Get alerted when CVE-2022-0494 or the next vulnerability affects your stack