What’s Vulnerable › Vulnerabilities
CVE-2022-0501: Cross-site Scripting (XSS) - Reflected in ptrofimov/beanstalk_console
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in Packagist ptrofimov/beanstalk_console prior to 1.7.12.
Affected products
- ptrofimov/beanstalk_console: before 1.7.12 — fixed in 1.7.12
How to fix
Upgrade to a fixed version: ptrofimov/beanstalk_console 1.7.12. Check the vendor advisory for mitigations.
References
- https://github.com/ptrofimov/beanstalk_console/commit/e351c8260ec1d3718d9e475ee57c7e12c47f19da
- https://huntr.dev/bounties/9af1c35e-3f74-4c93-a241-e8be01335ec7
- https://github.com/ptrofimov/beanstalk_console/commit/e351c8260ec1d3718d9e475ee57c7e12c47f19da
- https://huntr.dev/bounties/9af1c35e-3f74-4c93-a241-e8be01335ec7
Get alerted when CVE-2022-0501 or the next vulnerability affects your stack