What’s Vulnerable › Vulnerabilities
CVE-2022-0506: Cross-site Scripting (XSS) - Stored in microweber/microweber
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in Packagist microweber/microweber prior to 1.2.11.
Affected products
- microweber/microweber: before 1.2.11 — fixed in 1.2.11
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/05d55f2befb1b25375ca5371875ff535d6cc5f70
- https://huntr.dev/bounties/0a5ec24c-343e-4cc4-b27b-2beb19a1c35f
- https://github.com/microweber/microweber/commit/05d55f2befb1b25375ca5371875ff535d6cc5f70
- https://huntr.dev/bounties/0a5ec24c-343e-4cc4-b27b-2beb19a1c35f
Get alerted when CVE-2022-0506 or the next vulnerability affects your stack