What’s Vulnerable › Vulnerabilities
CVE-2022-0509: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in Packagist pimcore/pimcore prior to 10.3.1.
Affected products
- pimcore/pimcore: before 10.3.1 — fixed in 10.3.1
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/6ccb5c12fc1be065ebce9c89c4677ee939b88597
- https://huntr.dev/bounties/26cdf86c-8edc-4af6-8411-d569699ecd1b
- https://github.com/pimcore/pimcore/commit/6ccb5c12fc1be065ebce9c89c4677ee939b88597
- https://huntr.dev/bounties/26cdf86c-8edc-4af6-8411-d569699ecd1b
Get alerted when CVE-2022-0509 or the next vulnerability affects your stack