What’s Vulnerable › Vulnerabilities
CVE-2022-0517
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-434
Description
Mozilla VPN can load an OpenSSL configuration file from an unsecured directory. A user or attacker with limited privileges could leverage this to launch arbitrary code with SYSTEM privilege. This vulnerability affects Mozilla VPN < 2.7.1.
Affected products
- Mozilla VPN 2.16.1: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: Mozilla VPN 2.16.1 2.7.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1752291
- https://www.mozilla.org/security/advisories/mfsa2022-08/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1752291
- https://www.mozilla.org/security/advisories/mfsa2022-08/
Get alerted when CVE-2022-0517 or the next vulnerability affects your stack