What’s Vulnerable › Vulnerabilities
CVE-2022-0528: Server-Side Request Forgery (SSRF) in transloadit/uppy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-03 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) in GitHub repository transloadit/uppy prior to 3.3.1.
Affected products
- transloadit/uppy: before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: transloadit/uppy 3.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/transloadit/uppy/commit/267c34045a1e62c98406d8c31261c604a11e544a
- https://huntr.dev/bounties/8b060cc3-2420-468e-8293-b9216620175b
- https://github.com/transloadit/uppy/commit/267c34045a1e62c98406d8c31261c604a11e544a
- https://huntr.dev/bounties/8b060cc3-2420-468e-8293-b9216620175b
Get alerted when CVE-2022-0528 or the next vulnerability affects your stack