What’s Vulnerable › Vulnerabilities
CVE-2022-0535: E2Pdf < 1.16.45 - Admin+ Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The E2Pdf WordPress plugin before 1.16.45 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- e2pdf: before 1.16.45 — fixed in 1.16.45
How to fix
Upgrade to a fixed version: e2pdf 1.16.45. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2675049/e2pdf
- https://wpscan.com/vulnerability/a4162e96-a3c5-4f38-a60b-aa3ed9508985
- https://plugins.trac.wordpress.org/changeset/2675049/e2pdf
- https://wpscan.com/vulnerability/a4162e96-a3c5-4f38-a60b-aa3ed9508985
Get alerted when CVE-2022-0535 or the next vulnerability affects your stack