What’s Vulnerable › Vulnerabilities
CVE-2022-0539: Cross-site Scripting (XSS) - Stored in ptrofimov/beanstalk_console
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in Packagist ptrofimov/beanstalk_console prior to 1.7.14.
Affected products
- ptrofimov/beanstalk_console: before 1.7.14 — fixed in 1.7.14
How to fix
Upgrade to a fixed version: ptrofimov/beanstalk_console 1.7.14. Check the vendor advisory for mitigations.
References
- https://github.com/ptrofimov/beanstalk_console/commit/5aea5f912f6e6d19dedb1fdfc25a29a2e1fc1694
- https://huntr.dev/bounties/5f41b182-dda2-4c6f-9668-2a9afaed53af
- https://github.com/ptrofimov/beanstalk_console/commit/5aea5f912f6e6d19dedb1fdfc25a29a2e1fc1694
- https://huntr.dev/bounties/5f41b182-dda2-4c6f-9668-2a9afaed53af
Get alerted when CVE-2022-0539 or the next vulnerability affects your stack