What’s Vulnerable › Vulnerabilities
CVE-2022-0542: Cross-site Scripting (XSS) - DOM in chatwoot/chatwoot
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository chatwoot/chatwoot prior to 2.7.0.
Affected products
- chatwoot/chatwoot: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: chatwoot/chatwoot 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/chatwoot/chatwoot/commit/dd1fe4f93a6fbafa1d1eed87ac7d4143e701ec08
- https://huntr.dev/bounties/e6469ba6-03a2-4b17-8b4e-8932ecd0f7ac
- https://github.com/chatwoot/chatwoot/commit/dd1fe4f93a6fbafa1d1eed87ac7d4143e701ec08
- https://huntr.dev/bounties/e6469ba6-03a2-4b17-8b4e-8932ecd0f7ac
Get alerted when CVE-2022-0542 or the next vulnerability affects your stack