What’s Vulnerable › Vulnerabilities
CVE-2022-0544
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-191
Description
An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.
Affected products
- Blender: before 2.83.19; from 2.90.0 before 2.93.8; from 3.0 before 3.1 — fixed in 2.83.19, 2.93.8, 3.1
- Debian Linux: 9.0, 10.0
How to fix
Upgrade to a fixed version: Blender 2.83.19, 2.93.8, 3.1. Check the vendor advisory for mitigations.
References
- https://developer.blender.org/T94661
- https://lists.debian.org/debian-lts-announce/2022/06/msg00021.html
- https://www.debian.org/security/2022/dsa-5176
- https://developer.blender.org/T94661
- https://lists.debian.org/debian-lts-announce/2022/06/msg00021.html
- https://www.debian.org/security/2022/dsa-5176
Get alerted when CVE-2022-0544 or the next vulnerability affects your stack