What’s Vulnerable › Vulnerabilities
CVE-2022-0545
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow in the processing of loaded 2D images leads to a write-what-where vulnerability and an out-of-bounds read vulnerability, allowing an attacker to leak sensitive information or achieve code execution in the context of the Blender process when a specially crafted image file is loaded. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.
Affected products
- Blender: before 2.83.19; from 2.90.0 before 2.93.8; from 3.0.0 before 3.1.0 — fixed in 2.83.19, 2.93.8, 3.1.0
- Debian Linux: 10.0, 11.0
How to fix
Upgrade to a fixed version: Blender 2.83.19, 2.93.8, 3.1.0. Check the vendor advisory for mitigations.
References
- https://developer.blender.org/T94629
- https://lists.debian.org/debian-lts-announce/2022/06/msg00021.html
- https://www.debian.org/security/2022/dsa-5176
- https://developer.blender.org/T94629
- https://lists.debian.org/debian-lts-announce/2022/06/msg00021.html
- https://www.debian.org/security/2022/dsa-5176
Get alerted when CVE-2022-0545 or the next vulnerability affects your stack