What’s Vulnerable › Vulnerabilities
CVE-2022-0547
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-18 · updated 2026-06-17
- Weakness: CWE-305
Description
OpenVPN 2.1 until v2.4.12 and v2.5.6 may enable authentication bypass in external authentication plug-ins when more than one of them makes use of deferred authentication replies, which allows an external user to be granted access with only partially correct credentials.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 34, 36
- OpenVPN: from 2.1.0 before 2.4.12; from 2.5.0 before 2.5.6 — fixed in 2.4.12, 2.5.6
How to fix
Upgrade to a fixed version: OpenVPN 2.4.12, 2.5.6. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/openvpn/wiki/CVE-2022-0547
- https://community.openvpn.net/openvpn/wiki/SecurityAnnouncements
- https://lists.debian.org/debian-lts-announce/2022/05/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFXJ35WKPME4HYNQCQNAJHLCZOJL2SAE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R36OYC5SJ6FLPVAYJYYT4MOJ2I7MGYFF/
- https://openvpn.net/community-downloads/
- https://community.openvpn.net/openvpn/wiki/CVE-2022-0547
- https://community.openvpn.net/openvpn/wiki/SecurityAnnouncements
- https://lists.debian.org/debian-lts-announce/2022/05/msg00002.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00005.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFXJ35WKPME4HYNQCQNAJHLCZOJL2SAE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R36OYC5SJ6FLPVAYJYYT4MOJ2I7MGYFF/
Get alerted when CVE-2022-0547 or the next vulnerability affects your stack