What’s Vulnerable › Vulnerabilities

CVE-2022-0549

Description

An issue has been discovered in GitLab CE/EE affecting all versions before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. Under certain conditions, GitLab REST API may allow unprivileged users to add other users to groups even if that is not possible to do through the Web UI.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.6.5, 14.7.4, 14.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-0549 or the next vulnerability affects your stack