What’s Vulnerable › Vulnerabilities
CVE-2022-0554: Use of Out-of-range Pointer Offset in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-10 · updated 2026-06-17
- Weakness: CWE-823
Description
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34
- vim/vim: before 8.2.4327 — fixed in 8.2.4327
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.4327. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/e3537aec2f8d6470010547af28dcbd83d41461b8
- https://huntr.dev/bounties/7e8f6cd0-b5ee-48a2-8255-6a86f4c46c71
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/e3537aec2f8d6470010547af28dcbd83d41461b8
Get alerted when CVE-2022-0554 or the next vulnerability affects your stack