What’s Vulnerable › Vulnerabilities
CVE-2022-0563
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-21 · updated 2026-10-14
- Weakness: CWE-209
Description
A flaw was found in the util-linux chfn and chsh utilities when compiled with Readline support. The Readline library uses an "INPUTRC" environment variable to get a path to the library config file. When the library cannot parse the specified file, it prints an error message containing data from the file. This flaw allows an unprivileged user to read root-owned files, potentially leading to privilege escalation. This flaw affects util-linux versions prior to 2.37.4.
Affected products
- util-linux: before 2.37.4 — fixed in 2.37.4
- NetApp ONTAP Select Deploy administration utility: all versions
How to fix
Upgrade to a fixed version: util-linux 2.37.4. Check the vendor advisory for mitigations.
References
- https://lore.kernel.org/util-linux/20220214110609.msiwlm457ngoic6w%40ws.net.home/T/#u
- https://security.gentoo.org/glsa/202401-08
- https://security.netapp.com/advisory/ntap-20220331-0002/
- https://lore.kernel.org/util-linux/20220214110609.msiwlm457ngoic6w%40ws.net.home/T/#u
- https://security.gentoo.org/glsa/202401-08
- https://security.netapp.com/advisory/ntap-20220331-0002/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2022-0563 or the next vulnerability affects your stack